I'm using GIMP 2.4.5 Tiger build on OS X

I have two seemingly simple problems/issues/disconnects:

problem #1:

last night after working late into the night on a CD project in GIMP
I inadvertently screwed up how my selection and move tools behave
I think I hit the backspace key ('delete' on Apple) in the 'Config Keyboard Shortcuts' but not sure...
late night and very tired

I started using GIMP again after a year or and I had encountered this same issue a while back but I managed to get GIMP into the mode I prefer working in by tweaking something in the prefs or in a menu somewhere (I can't remember what I did to fix it)

but essentially here is the problem:

I want to be in a mode (like in Photoshop) where I can make and move a selection I'm working in and not the entire layer

for example:

start with a white background (say 640 x 480)
then make a transparent layer on top
I then drag out a rectangle on 2nd payer with the select rectangle tool
then fill it with a color (bucket tool or drag the color to it)
then I switch to the 'move' tool
and try to move the colored rectangle with a dotted line around it
but what happens is that I end up moving the entire layer
or (depending on the Affect settings for Move) I end up moving the rectangular selection (w/ dotted line) leaving behind the colored box

I've messed with the move tool box settings
I've tried changing the Affect settings to Move layer, Move selection but it doesn't seem to work and I'm still not able to get my settings back to where I had them earlier this week
where I could create a layer
make a shape
put something in it
and move it around

it would seem logical that the Move selection would be what I want but

this is a very confusing and non-obvious aspect to GIMP
that someone ought to make clear via the UI
I feel the expected behavior is that I can move the color rect in the selection by using the move tool

has anyone experienced this? if so, where is the secret tweak that makes it behave the way I want it to?

problem #2:

I've downloaded hundreds of very useful brushes and originally had placed them individually root in the brushes folder the loading of all these brushes greatly slowed down the launch process which often times took 3 or more minutes

-- I now know that I should have left them in their original folders and not dragged them directly into my brushes folder --

I then went into my GIMP/brushes folder and made individual folders for each group of brushes then I opened the Prefs/Folders/Brushes panel and started to create links to each of my brush folders

after I add the 15th folder in my brushes directory/folder I got several behaviors:

- the first attempt the folders in the Brushes panel displayed doubled...
   - for example
although there was only one instance of each folder in my /Brushes folder

- second behavior:
I was able to add more than 15 folders to the list i.e. they show up
but after I shut the window and re-opened it everything over 15 folders disappeared

- third behavior:
I attempted to add more than 15 folders but they wouldn't add to the list
and when I shut the window and re-opened they were not added to the list


can anyone help me on these two problems
I suspect the first one is a n00b issue
while the second might be an actual limitation or bug

thanks in advance
Kim Cascone
Gimp-user mailing list

Reply via email to