On Sat 10 May 2008 12:45:09 pm Sven Neumann wrote:
> Hi,
>
> On Sat, 2008-05-10 at 17:00 +0300, peter kostov wrote:
> > Procedure 'gimp-drawable-width' has been called with an invalid ID for
> > argument 'drawable'. Most likely a plug-in is trying to work on a layer
> > that doesn't exist any longer.
> >
> > And an 'RuntimeError: execution error' message on the console.
> >
> > I have googled, but not managed to find any answer :(
> >
> > How should I get the 'drawable' and what exactly should I feed to the
> > resynthesize plug-in as 'DRAWABLE'?
>
> The drawable you are passing looks just right. But doesn't the
> resynthesizer PDB procedure take run-mode as its first parameter?
>
When caling PDB stuff from a python plug-in, the run-mode
parameter is always omited and assumed to be "non-interactive"


>
> Sven
>
>
> _______________________________________________
> Gimp-user mailing list
> Gimp-user@lists.XCF.Berkeley.EDU
> https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-user


_______________________________________________
Gimp-user mailing list
Gimp-user@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-user

Reply via email to