Hello list, I've encountered an issue but I'm not sure whether it's a user
error, a bug, or just a feature of the way the program works.  I'd be
grateful for any insight that anyone could give.

I'm running the Windows binary of GIMP 2.4.6 on Windows XP SP2.

What I really want to get is the Print Size in Image > Image Properties
displayed in mm rather than inches, but in trying to find out how to do
this, I discovered the following: in Image > Print Size (the resulting
dialog is titled Set Image Print Resolution), changing the units for Print
Size width and height doesn't 'stick': if I change the units from inches to
anything else, the width and height values change appropriately, but when I
OK out of the dialog then come back in, the units have reverted to inches,
and the numbers to their inch values.

Changes made to the X and Y resolution in the same dialog do persist.

It does not appear to be due to the units used for resolution - if I change
this to pixels/mm the size units still refuse to be anything other than

The problem exists whether the image has been created with a size defined in
pixels or millimeters, and with a resolution defined in pixels/mm or
pixels/in.  I've tried with the defaults in Preferences defined in mm and
pixels/mm and using inches.  The default paper size is A4, defined in mm.  I
have mm selected as the unit in the status bar, and all other sizes are in
mm, including the grid and results from the measure tool, with one -
presumably linked - exception: File > Print > Image Settings initially
appears using inches.  If I change this to mm and print the image (the apply
button in this dialog remains unavailable, and cancel, unsurprisingly,
discards the changes), the change to mm does persist into subsequent visits
to the Print dialog - however the Print Size in Image Properties and Set
Image Print Resolution remains in inches.

Nothing appears in the error console.  The only vaguely related bug that I
can find listed is Bug 170200 from 2005 <
http://bugzilla.gnome.org/show_bug.cgi?id=170200 >, which was fixed.  I have
not tried the development branch, but there seems to be nothing relevant in
the changelist.

I did find various references to printing being buggy, especially on Windows
- could this be related?

Can anyone confirm this problem, or point out where I'm going wrong?  Thanks
a lot.
View this message in context: 
Sent from the Gimp User mailing list archive at Nabble.com.

Gimp-user mailing list

Reply via email to