After more testing and investigation, it looks like AWN is NOT to
blame in breaking the gimp in Hardy Heron. It was just mere coincidence that 
the installation of AWN also was the start of the gimp not working. 

I booted off the Ubuntu Hardy Heron Live CD and installed gimpshop via
dpkg -i. Both gimp and gimpshop worked perfectly. If you did a "ldd
`which gimp-2.4`", you would see that the gimp only loaded libraries in
/lib and /usr/lib and NOT any libraries installed by Gimpshop in

Since gimpshop was installed vua "dpkg -i", the library cache was never 

But then I did a "sudo ldconfig". Then gimp stopped working. (But
gimpshop still worked). If you did a "ldd `which gimp-2.4`", you would
see the gimp loading some (but not all) libraries from /usr/local/lib
where gimpshop installed libraries. 

When I installed AWN via apt-get, the library cache got regenerated (via 
ldconfig).  Then the gimp stopped working.

So it does look like a packaging issue. The gimpshop package should be
modified to show a conflict with gimp. But since the gimpshop project
appears to be dead that is not likely to happen.

Date: Thu, 24 Jul 2008 19:19:04 +0000
Subject: Re: [Gimp-user] AWN breaks the Gimp 2.4 in Ubuntu Hardy Heron

I found that problem. 

The Latest version of the Avant Window Manager (installed from the "deb hardy main" repo) BREAKS gimp 
2.4.5 in Hardy Heron 8.04.1.

You can easily verify that this is the problem.
1. Boot off the Hardy Heron 8.04.1 Live CD.

2. Add the repos:

deb hardy main

deb-src hardy main
( See )

3. sudo apt-get update

4. sudo apt-get install avant-window-navigator-bzr awn-core-applets-bzr 

5. Try to run gimp. It will not run. If you run gimp from the terminal, you 
will see the following error:

symbol lookup error: undefined symbol: gimp_micro_version

Now try to get gimp to run again. I can't!
I tried to COMPLETELY uninstall the following:

awn (using the instructions on the




I even manually deleted the .gimp-2.4/ folder in my home directory.
Then deleted the AWN third party rep sources and reinstalled gimp. I
still see the error.

This bug is VERY annoying.  I would really like to get gimp running again. 

Any Ideas?



Gimp-user mailing list

Reply via email to