For one of the many usual reasons, I had to wipe my c:\ hard drive and 
re-install Vista Home Premium and all my software.

specifically, I followed the directions in to 
get Python-Fu working again -- NOT!

Specifically, the first recommended step is to get Python 2.6. The hot link 
from the above page to vectors you to the 
Python 2.6.7 page whence you can get ONLY the source code for the latest 
revision of Python 2.6. Well I don't know how to compile C++ code but I did 
search Google for "Python 2.6" and found which allowed me to download 
python-2.6.6.msi which seemed to install Python in c:\Phthon26.

Going back to the GimpUsers tutorial, I next hotlinked to PyGTK Downloads at and tried to install the recommended 
all-in-one installer: pygtk-all-in-one-2.24.0.win32-py2.6.msi. Alas, it bombed 
out because something that whomever put the installer package together was 
supposed to set in some table somewhere, TARGETDIR, was somehow wonky. Well, 
that was way over my pay-grade so I fell back on getting PyGTK, PyCairo, and 
PyGObject from: - 
pygtk-2.24.0.win32-py2.6.exe - 
pycairo-1.8.10.win32-py2.6.exe - 

They installed just fine. Then I re-installed GIMP as per the tutorial. But 
when I tried to run GIMP, I got a zillion error messages, all saying that "The 
procedure entry point g_malloc_n could not be located in the dynamic link 
library libglib-2.0.0.dll." followed by Microsoft Windows saying that 
"unsharp-mask.exe has stopped working." Followed by the same error message for 
softglow.exe, etc., etc. I gave up and used Task Manager to shut down the GIMP 

I suspect I am in the well-known "DLL hell." Firstly it is my dim understanding 
that some DLLs do not, in fact, contain executable code and contain, instead, 
just "pointers" to who-knows-what, who-knows-where. Secondly, as DLLs got 
updated by who-knows-whom, this or that program, that used a common DLL, needed 
this or that prior revision of the DLL -- which turned out to be a huge mess 
(hence the term "DLL hell"). Which problem was "cured" in Vista by simply 
saving EVERY version of EVERYTHING in a huge hidden file.

The Python people are up to version 3.7 or so and we GIMPers are still using 
version 2.6. I tried as hard as I could to get all the right versions of 
Python, PyGTK, PyCairo, and PyGOject. Python-fu usta-did-work for me before my 
re-install. Can anybody tell me where I went wrong and what I should install 
instead of the above and/or what to do about the DLL(s) in the error message? 

charlessmall18 (via
Gimp-user mailing list

Reply via email to