> git branch mybranch remotes/origin/mybranch
> git co mybranch
> I had created the co alias for checkout and the upci alias.
> I tried this and modified a file followed by
> git commit -a -m "test file update"
> git upci
> It gave me an error message unable to determine upstream SVN
> information from HEAD history.
> Was there a step that I missed?

One note: I usually use git co -t origin/mybranch, so it is created as
a tracking branch.

This error message is very typical. It means that git-svn doesn't
recognize which commits come from SVN.

Usually you get this if the reference in .git/refs/remotes/[branch] is
missing or wrong.

It can also occur in some other situations that I can't remember from
the top of my head.

So it's hard to say. I would first step away from the "upci" alias for
a bit, and use the manual update-ref + dcommit commands again, just to
be sure that there's not a bug in the alias.

Do this:

git update-ref refs/remotes/[branch] refs/remotes/origin/[branch]

... followed by git svn dcommit.

If this still doesn't work, please post back here with the following
info, so I can make a more educated guess on what's wrong:

1. The output from git config -l
2. Log of the last few (say, 5) commits in SVN branch
3. Log of the last few commits in the git repo
4. Output from git remote show origin

You received this message because you are subscribed to the Google Groups "Git 
for human beings" group.
To post to this group, send email to git-users@googlegroups.com.
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to