On 31/10/2013 14:45, Konstantin Khomoutov wrote:
On Thu, 31 Oct 2013 13:23:50 +0000
Roddie Grant <gitl...@myword.co.uk> wrote:

For the record, I had to use 'git --no-pager diff' rather 'git diff
--no-pager'. It solved the problem, but I was connected to the server.

Using 'setenv LESSCHARSET utf-8' works, but only when I've ssh-ed to
the remote web server. Making it persistent in Terminal (on the local
Mac) has no effect. But if I connect to the server, then do 'setenv
LESSCHARSET utf-8' before running git diff, I get the proper
apostrophes etc.

I've added 'setenv LESSCHARSET utf-8' to my .tcshrc file on the web
server and all is well.

I'm glad this helped but please next time be clear about what you're
doing.  I tried to re-read your original message in this thread and
again failed to gather from it that your problem actually occured in
an SSH session with a remote machine!  SSH wasn't mentioned at all.
I was sure you were having problems seeing a diff on your local system
(Mac OS) directly running Git in Terminal.

My apologies. I tried to keep the description of the problem succinct, but overdid it. The significance of the SSH session wasn't obvious to me :-( It just appeared to be Terminal being awkward.

You received this message because you are subscribed to the Google Groups "Git for 
human beings" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to git-users+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to