I wrote:

> it is not possible to build RPMs from the current git code:
> RPM build errors:
>     Installed (but unpackaged) file(s) found:
>    /usr/share/git-core/templates/description
>    /usr/share/git-core/templates/hooks/post-update
>    /usr/share/git-core/templates/hooks/update
>    /usr/share/git-core/templates/info/exclude
> make: *** [rpm] Error 1

A simple fix is of course:

-> diff -u git-core.spec.in.ORIG git-core.spec.in
--- git-core.spec.in.ORIG       2005-08-09 10:26:50.845877000 +0200
+++ git-core.spec.in    2005-08-09 12:42:06.872310918 +0200
@@ -40,6 +40,7 @@
 %{!?_without_docs: %doc Documentation/*.html }
 %{!?_without_docs: %{_mandir}/man1/*.1.gz}
 %{!?_without_docs: %{_mandir}/man7/*.7.gz}
 * Thu Jul 14 2005 Eric Biederman <[EMAIL PROTECTED]>

But the resulting RPM cannot be installed either,  at  least  not  in
standard Fedora Core 2/3/4 installations:

error: Failed dependencies:
        perl(Email::Valid) is needed by git-core-0.99.3-1
        perl(Mail::Sendmail) is needed by git-core-0.99.3-1

Seems git is depending on more and more stuff which is not  available
in standard distros. This makes it not easier for new users...

Is there at least some  documentation  which  external  packages  are
needed, and where to find these?

Best regards,

Wolfgang Denk

Software Engineering:  Embedded and Realtime Systems,  Embedded Linux
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: [EMAIL PROTECTED]
"There are three principal ways to lose money: wine, women,  and  en-
gineers.  While  the first two are more pleasant, the third is by far
the more certain."                      -- Baron Rothschild, ca. 1800
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to