Yesterday I was all happy ... Linus pulled a couple of changes from
my tree, and after I did a pull back from his tree into my "linus"
tracking branch, my status scripts correctly identified the branches
that I'd been using to track those changes as being no longer needed.

But this morning I ran another one of my status scripts that does

 $ git-whatchanged -p test ^linus | diffstat -p1

and was surprised when it reported changes in 10 files that I knew
I hadn't touched (the other 18 files it reported looked correct).

So I ran:

 $ git-whatchanged test ^linus | git-shortlog

and this just reported the changesets that I expected.

 $ git-diff-tree -p linus test | diffstat -p1

shows what I expect to see.

The current heads of the two branches are:

linus=30d5b64b63fa69af31b2cba32e6d71d68526eec9
test=0e595ad82db1b42d631e581630eb3fbeebb3c285

my tree is at:
rsync://rsync.kernel.org/pub/scm/linux/kernel/git/aegl/linux-2.6.git

The spurious changes reported by "git-whatchanged -p" are:

>  Documentation/acpi-hotkey.txt              |    3 
>  Documentation/kernel-parameters.txt        |    5 
>  drivers/acpi/osl.c                         |    6 
>  fs/jfs/inode.c                             |    4 
>  fs/jfs/jfs_logmgr.c                        |   36 -
>  fs/jfs/jfs_logmgr.h                        |    2 
>  fs/jfs/jfs_txnmgr.c                        |   12 
>  fs/jfs/super.c                             |    4 
>  include/asm-i386/processor.h               |    2 
>  include/asm-x86_64/processor.h             |    2 

Is this a bug, or am I just confused about how "git-whatchanged" works?

-Tony
-
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to