> On 10 Aug 2016, at 19:17, Junio C Hamano <gits...@pobox.com> wrote:
> Jeff King <p...@peff.net> writes:
>> On Wed, Aug 10, 2016 at 03:36:45PM +0200, Lars Schneider wrote:
>>>> So now we have packet_write() and packet_write_gently(), but they differ
>>>> in more than just whether they are gentle. That seems like a weird
>>>> Should we either be picking a new name (e.g., packet_write_mem() or
>>>> something), or migrating packet_write() to packet_write_fmt()?
>>> Done in "[PATCH v5 08/15] pkt-line: rename packet_write() to
>> Ah, OK. Generally I'd suggest to reorder things so that each patch looks
>> like a step forward (and so the early patches become preparatory steps,
>> and the justification in them is something like "we're going to add more
>> write functions, so let's give this a more descriptive name").
> I am guilty for saying "packet_write() should have been similar to
> write(2)". We may want to have a time-period during which there is
> no "packet_write()" in the codebase, before we get to that stage.
> I.e. rename it to packet_write_fmt() to vacate the name and add
> packet_write_mem(), and then later rename packet_write_mem() to its
> final name packet_write(), or something like that. The two-step
> process would reduce the chance of misconversion.
OK. Does this mean I can leave the "packet_write()" to "packet_write_fmt()"
rename as is in this series?
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html