Hello Stefano,

Thank you for your quick answer. You are right, HP-UX have a gmake executable :

#gmake --version
GNU Make 3.81
Copyright (C) 2006  Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A

This program built for ia64-hp-hpux11.31

I will try to use this instead of make 


TMA EAI - Division Telecom & Media
Sopra group.
Centre Espace Performance - Batiment S
35769 St Grégoire
Phone : +33 (0)2 23 25 34 71
ronan.quin...@sopragroup.com - www.sopragroup.com

Ce message peut contenir des informations confidentielles dont la divulgation 
est à ce titre rigoureusement interdite en l'absence d'autorisation explicite 
de l'émetteur. Dans l'hypothèse où vous auriez reçu par erreur ce message, 
merci de le renvoyer à l’émetteur et de détruire toute copie.

 Pensez à l’environnement avant d’imprimer.

-----Message d'origine-----
De : Stefano Lattarini [mailto:stefano.lattar...@gmail.com] 
Envoyé : mercredi 14 novembre 2012 12:26
À : Quintin Ronan
Cc : git@vger.kernel.org
Objet : Re: Unable to compile Git on HP-UX B.11.31 U ia64

On 11/14/2012 12:18 PM, Quintin Ronan wrote:
> Hello,
> I’m trying to compile git 1.7 on a HPUX server using make.
> The ./configure worked well :
> [SNIP]
> But when i run make (with –d) it simply doesn’t work with a message
> which isn’t really helpfull :
>   [SNIP]
>   Make: line 313: syntax error.  Stop.
> Can you help me ?
The Git build system requires GNU make, but it seems to me you are using
your system native make instead.  That won't work.  It might be the case
GNU make is installed on your system, but is named something like 'gmake'
or 'gnumake' rather than just 'make'.  What happens if you run the

   $ gmake --version
   $ gnumake --version

If GNU make is not installed on your system, you can download the latest
version from here:


For more information about GNU make:



Reply via email to