David Aguilar <dav...@gmail.com> writes:

> On Tue, Jan 29, 2013 at 11:22 AM, John Keeping <j...@keeping.me.uk> wrote:
>> On Sun, Jan 27, 2013 at 04:52:23PM -0800, David Aguilar wrote:
>>> Update variable assignments to always use $(command "$arg")
>>> in their RHS instead of "$(command "$arg")" as the latter
>>> is harder to read.  Make get_merge_tool_cmd() simpler by
>>> avoiding "echo" and $(command) substitutions completely.
>>> Signed-off-by: David Aguilar <dav...@gmail.com>
>>> ---
>>> @@ -300,9 +292,9 @@ get_merge_tool_path () {
>>>       fi
>>>       if test -z "$merge_tool_path"
>>>       then
>>> -             merge_tool_path="$(translate_merge_tool_path "$merge_tool")"
>>> +             merge_tool_path=$(translate_merge_tool_path "$merge_tool")
>>>       fi
>>> -     if test -z "$(get_merge_tool_cmd "$merge_tool")" &&
>>> +     if test -z $(get_merge_tool_cmd "$merge_tool") &&
>> This change should be reverted to avoid calling "test -z" without any
>> other arguments, as Johannes pointed out in v1.
>> The rest of this patch looks good to me.
> You're right.  My eyes have probably been staring at it too long and I
> missed this (even though I thought I had checked).

By now you (and people who were following this thread) are beginning
to see why I said "I'd feel safer with extra dq" ;-)

I'll amend locally and push the result out.
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to