On Mon, Aug 12, 2019 at 01:10:54AM +0000, brian m. carlson wrote: > On 2019-08-12 at 00:32:26, Junio C Hamano wrote: > > "brian m. carlson" <sand...@crustytoothpaste.net> writes: > > > +static ssize_t stripped_path_suffix_offset(const char *path, const char > > > *suffix) > > > > Perhaps > > > > static ssize_t last_path_component_offset(const char *path, const char > > *name) > > > > I am tempted to also call the second parameter to this function > > "basename", as we know from the proposed log message that you wish > > "basename" were usable for this purpose, but basename itself has > > another confusing factor (i.e. "are we stripping ".exe" extension?", > > to which the answer is no in the context of these functions). > > > > If we agree with the "last path component" phrasing, has_path_suffix() > > would become something like: > > > > int last_path_component_equals(const char *path, const char *name); > > Except this is not necessarily the last path component. It could match > one or more path components with the way the function is written. If you > want to ignore that and name the function accordingly, I won't object, > but we could theoretically handle a name like "foo/.gitattributes" as > well.
ends_with_path_components(), perhaps? I think having "path_component" in some form in the function name would have avoided my confusion mentioned earlier in a reply to the first version.