Hi, Here is a small patch with QNX build improvements:
1) Rename tar.h to tar_git.h. Latest QNX versions have system tar.h header according to http://pubs.opengroup.org/onlinepubs/009696699/basedefs/tar.h.html , to avoid inclusion of another tar.h, original header was renamed. 2) Rename fnmatch.h to fnmatch_gnu.h and fnmatch.c to fnmatch_gnu.c to avoid inclusion of system fnmatch.h header in case if -I/usr/include path is specified before -Icompat/fnmatch. Which is common situation. 3) pager.c - default "less" invocation flags were changed for QNX 6,x platform, since QNX has incompatible with GNU coreutils version of "less" utility. 4) config.mak.uname - a) do not override mkdtemp/mkstemps/strcasestr detection, since newer QNX version could contain such functions. Let to configure decide what is present in the system. b) getpagesize() function is existing under QNX, c) QNX has pthread functions in the libc, so do not define NO_PTHREAD macro. Thanks in advance!
Description: Binary data