From: "Ramkumar Ramachandra" <>
Sent: Wednesday, March 20, 2013 12:44 PM
This follows-up [1], with three important differences:

1. pushremote_get() and remote_get() share code better.  Thanks Jeff.

2. All spelling mistakes have been corrected.  Thanks Eric.

3. One new test for each of the new configuration variables.  The
extra two parts [2/6] and [3/6] preprare the file for introducing
tests.  However, I've not gone overboard in this preparation; I don't
replicate the work done by Jonathan in [2].

Thanks for reading.


Ramkumar Ramachandra (6):
 remote.c: simplify a bit of code using git_config_string()
 t5516 (fetch-push): update test description
 t5516 (fetch-push): introduce mk_test_with_name()
 remote.c: introduce a way to have different remotes for fetch/push
 remote.c: introduce remote.pushdefault
 remote.c: introduce branch.<name>.pushremote

Documentation/config.txt | 23 +++++++++++++++---

Shouldn't Documentation/gitworkflows.txt also be updated with the triangular workflow and its configuration?

builtin/push.c           |  2 +-
remote.c                 | 36 +++++++++++++++++++++------
remote.h                 |  1 +
t/ | 63 ++++++++++++++++++++++++++++++++++++++++--------
5 files changed, 104 insertions(+), 21 deletions(-)


To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to
More majordomo info at

Reply via email to