On Sun, Apr 14, 2013 at 12:48:00PM +0400, Ilya Basin wrote:
> IB> Hi esr.
> IB> In cvsps 3.10 the flag --norc was removed. It broke 'git cvsimport'.
> IB> Please give the option back and write something in the man page like:
> IB>     This option has no effect; it is present for compatibility
> Looks like the tool is completely different. I think I'll have to
> downgrade.

If you want incremental import support, then that's the best thing to
do.  There was some discussion about this in January [1] and it doesn't
look like cvsps-3 has changed since then, so if you want to
incrementally update a Git clone of a CVS repository then cvsps-2 is
really the only way to go.

If you're doing a one-off import then I recommend ignoring git-cvsimport
and investigating cvs2svn[2] and cvs-fast-export [3].

[1] http://thread.gmane.org/gmane.comp.version-control.git/214258/focus=214305
[2] http://cvs2svn.tigris.org/cvs2git.html
[3] https://gitorious.org/cvs-fast-export
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to