Junio C Hamano wrote:
> Revert 77c1305 and 3c3b46b
The core of the argument seems to be that
__git_complete_revlist_file() is a misleading name for the completion
done by archive and ls-tree, but __git_complete_file() is somehow a
less misleading name? Irrespective of what the valid completions of
the various commands are, I want to know which completion function
will be _used_ when I'm reading the script. And that is
To me, it looks like mega-bikeshedding; a huge amount of time and
effort going behind a non-functional variable rename (and the best
part? the rename isn't getting us a "better" name; just a "historical"
name). But whatever.
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html