Christian Couder <christian.cou...@gmail.com> writes:
> On Thu, Dec 19, 2013 at 7:58 PM, Junio C Hamano <gits...@pobox.com> wrote:
>> Christian Couder <christian.cou...@gmail.com> writes:
>>> I think this last one might be useful for people replacing objects
>>> with objects that have another type.
>> ... which IIUC is strongly discouraged---didn't you have to tighten
>> it recently?
>> And that makes it "useful primarily for debugging" unusual
> Ok, so would you prefer the following:
> - NAME_ONLY_REPLACE_FMT and "--format=name_only" instead of
> SHORT_REPLACE_FMT and "--format=short"
> - NAME_AND_VALUE_REPLACE_FMT and "--format=name_and_value" instead of
> MEDIUM_REPLACE_FMT and "--format=medium"
> - DEBUG_REPLACE_FMT and "--format=debug" instead of FULL _REPLACE_FMT
> and "--format=full"
The end-user facing names are probably fine with short, medium,
full, as long as what they show are clearly explained in the
end-user documentation (patch 10/10 covers this).
I have a hunch that we may later regret "full" when somebody wants
to add even fuller information, though. It might be better spelled
I'd rather see REPLACE_FMT_ as a prefix, not suffix. Do we use
common suffix for enum values elsewhere?
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html