Conley Owens <> writes:

> On Fri, Feb 28, 2014 at 3:26 PM, Conley Owens <> wrote:
>> $ git --version  # This is just the git from MacPorts
>> git version
>> $ sw_vers
>> ProductName:    Mac OS X
>> ProductVersion: 10.8.5
>> BuildVersion:   12F45
> OK, I've tried using my own build from master, and I still get the same 
> results.
> I've done a little more investigation and discovered it always hangs at:
> `atexit(notify_parent);` in `run-command.c:start_command`
> when running:
> trace: run_command: 'git-remote-https' 'aosp'
> ''
> Could this have to do with the atexit implementation?  (eg. limit on
> the number of functions that can be registered, etc)


An interesting theory indeed.  I read that an implementation is
supposed to take at least ATEXIT_MAX (32) calls to atexit(3); while
I do think we register functions with atexit(3) from multiple places
in our code, I doubt we would be making that many.

> $ cc -v
> Apple clang version 4.1 (tags/Apple/clang-421.11.66) (based on LLVM 3.1svn)
> Target: x86_64-apple-darwin12.5.0
> Thread model: posix
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to
More majordomo info at

Reply via email to