On Thu, Mar 06, 2014 at 10:24:49AM -0800, Junio C Hamano wrote:

> > OK, I've tried using my own build from master, and I still get the same 
> > results.
> >
> > I've done a little more investigation and discovered it always hangs at:
> > `atexit(notify_parent);` in `run-command.c:start_command`
> > when running:
> > trace: run_command: 'git-remote-https' 'aosp'
> > 'https://android.googlesource.com/platform/external/tinyxml2'
> >
> > Could this have to do with the atexit implementation?  (eg. limit on
> > the number of functions that can be registered, etc)
> Thanks.
> An interesting theory indeed.  I read that an implementation is
> supposed to take at least ATEXIT_MAX (32) calls to atexit(3); while
> I do think we register functions with atexit(3) from multiple places
> in our code, I doubt we would be making that many.

It seems awfully weird that it would _hang_ in such a case, though. That
sounds more like hitting a mutex that's internal to atexit(), or
something similar.

Conley, can you see if dropping that atexit clears up the problem (you
should be OK without it; git will just fail to notice the child's
exec failure with as much detail).

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to