Silvola Tuomas wrote
> Hello,
> I installed git for windows 1.9.0 but any push operation I tried with it
> produced an error message saying "git: 'http-push' is not a git command".
> Other commands like pull, add, and commit worked just fine.
> At the end of this day I noticed that C:\Program Files
> (x86)\Git\libexec\git-core just didn't have the file git-http-push. There
> were git-http-backend, git-http-fetch and git-imap-send and such but no
> git-http-push.
> I resolved my issue by uninstalling 1.9.0, installing an older version
> instead (; this is when push started working) and 1.9.0 right on
> top of the older version. Now git push command works as expected.
> Br,
> Tuomas Silvola

>From Makefile:

        curl_check := $(shell (echo 070908; curl-config --vernum) 2>/dev/null |
sort -r | sed -ne 2p)
        ifeq "$(curl_check)" "070908"
                ifndef NO_EXPAT
                        PROGRAM_OBJS += http-push.o

if there's no curl-config, http-push.c is silently skipped. This check also
doesn't play with cross-compiling when you cannot call curl-config because
it is for other arch.

There's also a mystic git-http-push$X that is not referenced from anywhere.

View this message in context:
Sent from the git mailing list archive at
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to
More majordomo info at

Reply via email to