Am 03.07.2014 07:56, schrieb Torsten Bögershausen:
> On 07/02/2014 09:57 PM, Jens Lehmann wrote:
>> Am 02.07.2014 16:54, schrieb Torsten Bögershausen:
>>> (Not sure if this is the right thread)
>>> (I haven't checked if this is fixed in your latest version)
>> Yes, this is the right thread and no, it isn't fixed yet.
>>> On what I have on pu 7a0da7902cbbc9a876b90c9, Tue Jul 1 14:51:53 2014 -0700
>>> Many submodule tests are broken.
>>> One problem is here:
>>> possible problem: echo -n is not portable 
>>> (please use printf):                     echo -n >sub1 &&
>>> possible problem: echo -n is not portable 
>>> (please use printf):                     echo -n >sub1 &&
>>> You can remove the "empty" "echo -n" to create an empty file:
>>>> sub1 &&
>> Thanks for spotting and diagnosing this. Running "make lint" in the
>> test directory only feeds the tests to,
>> but not the *lib*.sh helper scripts, which made me miss this one.
>> The following diff should fix it for you. Am I understanding you
>> correctly that you are experiencing other failures too? I see no
>> other incompatibilities when running ./
>> on all the shell scripts in the repo.
> The longer story is that I run the test suite once a week or so.
> Most often under Mac OS, sometimes cygwin or Linux.
> Whenever there is a breakage under Mac OS which I can not
> debug within some minutes, I run it under Linux to see if there
> is the same breakage.

Thanks, that really helps a lot and is more than I could ask for.

> The ./ can sometimes give an indication
> why some test fail.
> You can run it from command line:
>  ./ *.sh
> and it will find the "echo -n" which I reported.
> On the longer run it could probably check all *.sh files,
> not only the ones under t/

That is exactly what I thought when I tried to find out why I missed
this. Will cook up a patch to at least check the test helpers too.

> I do not have the time to test the snipped patch below, but I can check pu
> when the next round of your patch is in and give you some more info.

That'd be great!

Junio, do you want me to resend 02/14 without the non-portable "echo -n"
or could you just squash the following diff in?

diff --git a/t/ b/t/
index 24c9fd7..3584755 100755
--- a/t/
+++ b/t/
@@ -304,7 +304,7 @@ test_submodule_switch () {
                        cd submodule_update &&
                        git branch -t add_sub1 origin/add_sub1 &&
-                       echo -n >sub1 &&
+                       >sub1 &&
                        test_must_fail $command add_sub1 &&
                        test_superproject_content origin/no_submodule &&
                        test_must_be_empty sub1
@@ -547,7 +547,7 @@ test_submodule_forced_switch () {
                        cd submodule_update &&
                        git branch -t add_sub1 origin/add_sub1 &&
-                       echo -n >sub1 &&
+                       >sub1 &&
                        $command add_sub1 &&
                        test_superproject_content origin/add_sub1 &&
                        test_dir_is_empty sub1

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to
More majordomo info at

Reply via email to