I am writing below couple of questions. If it is not the right place to ask 
please ignore and suggest me what to do to get the help on these questions.

1) What version of SSL is supported by GIT 1.8.3 or GIT 1.9.0

2) I have installed git 1.8.3 in AIX server 6.1 TL8 SP2. It worked fine and 
able to extract code from git repository directly as well as from ant. 
Everything went well.
Recently Aix OS upgraded to 6100-09-01-1341. After OS upgrade my git commands 
are not working. Basic help and version works fine as expected. When I try to 
pull the code from git repository it give SSL library compatibility issue.

The error is 
OpenSSL version mismatch. Built agains 1000105f, you have 100000bf
fatal: Could not read from remote repository

In order to get rid of this, I upgraded git to 1.9.0 GIT. But still it didn't 
work. The issue is still coming. 

git help, version works. 
When I tried directly pulling code using git pull command - didn't work.
When I try to pull the code through the ant - didn't work

The ant version is 1.8.0RC1

AIX admin worked on this and provided below comments

Comments form AIX system admin  (Pasted as it is)
Even after installing 1.9.0 version of GIT the library files are not compatible 
with the latest version of SSL (
SSL works fine as a root user and other users. This compatibility issue only a 
raises when the LIBPATH for GIT is set and the SSL picks up its LIBPATH from 
the same location as GIT and this causes the incompatibility.
Can you find out from the GIT/ANT support team on what version of SSL GIT 
supports exactly. - The is specifically with the GIT/SSL as the user "xyzabc" . 
The SSL otherwise works perfectly fine.
You will have to re-compile the ANT libraries to use the latest library files.

Thanks in advance.

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to