On Fri, Aug 01, 2014 at 07:30:11PM +0000, ravikirangoud_palpano...@vfc.com 
> Hi,
> I am writing below couple of questions. If it is not the right place
> to ask please ignore and suggest me what to do to get the help on
> these questions.
> 1) What version of SSL is supported by GIT 1.8.3 or GIT 1.9.0

The INSTALL file doesn't mention a particular OpenSSL version that we
require, but I know that it works with versions as old as 0.9.8 and as
new as 1.0.1g.  It may work with still older versions, but I recommend
1.0.1 or newer as it gives you proper TLS 1.2 support.

> 2) I have installed git 1.8.3 in AIX server 6.1 TL8 SP2. It worked
> fine and able to extract code from git repository directly as well as
> from ant. Everything went well.
> Recently Aix OS upgraded to 6100-09-01-1341. After OS upgrade my git
> commands are not working. Basic help and version works fine as
> expected. When I try to pull the code from git repository it give SSL
> library compatibility issue.
> The error isĀ 
> OpenSSL version mismatch. Built agains 1000105f, you have 100000bf
> fatal: Could not read from remote repository

OpenSSL 1.0.0 (which you were using before) and OpenSSL 1.0.1 are binary
compatible if compiled with the same flags, but they contain a hard
version check that fails if they're not the same version.

This means you need to recompile git against the newer OpenSSL version,
or ask your vendor to patch this check out.  This is true for any
program that gives you this error.

brian m. carlson / brian with sandals: Houston, Texas, US
+1 832 623 2791 | http://www.crustytoothpaste.net/~bmc | My opinion only
OpenPGP: RSA v4 4096b: 88AC E9B2 9196 305B A994 7552 F1BA 225C 0223 B187

Attachment: signature.asc
Description: Digital signature

Reply via email to