On 2018-02-10 10:37, Stan Brown wrote:
> I installed Gnucash 2.6.19 (from link at Gnucash.org) on my 64-bit
> Windows 7 laptop and 64-bit Windows 8 laptop and started working my way
> through the tutorial. ... I attempted to display the report of scheduled
> transactions. Got only a blank window, and when I clicked Close the
> title bar showed "not responding". When I clicked the red x in the upper
> right corner to close the window, I got "Gnucash has stopped working".
> The same thing happened with every report I tried (maybe ten of them,
> min various categories), and whether I had reports opening in a separate
> window or not. This happens on both my laptops.
I got several friendly and helpful replies, and felt it would be only
fair to follow the suggestions and give GnuCash a second try. This
weekend has been my first opportunity to do that. Two of the responders
suggested specific actions, and I'll reply to both in this message, but
I'd also like to thank everyone else who responded.

By the way, my motivation for trying GnuCash might be of interest to
some list members. I've posted that in a separate message to the list.

On 2018-02-10 20:14, David Carlson wrote:
> I suspect that you may not have gotten the correct release of 2.6.19
> for windows as I think there was a glitch early on that caused the
> crashing when opening reports that you mention. I believe the bug
> that you were trying to follow is very rare if it ever happens in
> Windows 10 or even Windows 7. It was more common in XP and Vista. You
> could try downloading a fresh copy of GnuCash and re-installing it
> again or use this link:
>
>
https://sourceforge.net/projects/gnucash/files/gnucash%20%28stable%29/2.6.19/gnucash-2.6.19-setup.exe/download.
>
> Some others have reported that reports are very slow to open in that
> release.
>
> I have not migrated to 2.6.19 myself, I am staying on release
> 2.6.18. It is also slow with very large files, but I do not have any
> issues with reports. Thus, I would suggest downloading and installing
> release 2.6.18. It is available here:
> 
>
https://sourceforge.net/projects/gnucash/files/gnucash%20%28stable%29/2.6.18/

On 2018-02-10 19:32, Ken Pyzik wrote:
> Stan -- I am using 2.6.19 on 64-bit Windows 10. While the reporting
> module is indeed very slow (bug report already out there was this)
> and while it does say "Not Responding", eventually the report does
> come up (after about 60-90 seconds).
> 
> I agree that it may be way too long -- but it does technically work.
> My belief is that it should work for you if given enough time.
I didn't understand David's comment about not getting the correct
release of 2.6.19, as I had downloaded it only a few days earlier, from
the link on the gnucash.org page, and the release was dated a month a
month and a half before that.

Before writing, I had uninstalled GnuCash 2.6.19 from both laptops.

As David suggested, I tried installing 2.6.18 in 64-bit Windows 8. (The
setup file downloaded from his link was labeled 2.6.18-3.) Since I had
also deleted my data files, I created a quick one using Common Accounts
in the wizard, and then tried for an Account Summary report. GnuCash
just sat there, with the tab window blank, and after a few seconds "Not
Responding" appeared in the title bar. I continued to wait, and after
about two minutes the report appeared.

Out of curiosity, I then installed GnuCash 2.6.19 again on my 64-bit
Windows 7 laptop. The same thing happened for the Account Summary! After
about two minutes of nothing (including nothing on the status line), the
report popped up in the tab. I don't know, now, whether the previous
install was actually crashing when I tried to generate reports, or when
I tried to cancel the report generation after a period of waiting with
no results.

At this point, I had reports, albeit very slow ones, on both laptops. I
decided to go ahead and create a new file with my own chart of accounts
and re-enter some of this year's transactions. Periodically as I did
this, in GnuCash 2.6.18 on Windows 8, I checked my work with one report
or another, principally the Account Summary, Balance Sheet, and General
Journal. To my surprise, all came up instantly. That's even better than
what Ken reported, and certainly different from my previous experience.
Of course the file isn't very large yet, probably just between one and
two hundred splits.

I then came back to my Windows 7 laptop, with GnuCash 2.6.19, and the
same thing happened -- I now get reports instantaneously.

I can't see any reason why uninstalling and reinstalling the program
would have fixed the problem with crashing on report production (or very
slow performance). And it seems weird that both versions, 2.6.18 as well
as 2.6.19, would take two minutes to produce their first report but then
produce all later reports very quickly. It's not Windows updates; none
were done between the two times I tried GnuCash.

The only difference I can see there is that the first report was against
a file created with just the Common Accounts from the wizard, and no
transactions, whereas the later reports were all created from my real
file, with my account structure, opening balances (via transaction, not
on the New Account dialog), and transactions for the first 3½ weeks of
January.

At this point the issue I reported is completely gone, so I'm soldiering
on to bring 2018 transactions up to date.

-- 
Regards,
Stan Brown
Tompkins County, New York, USA
http://BrownMath.com
http://OakRoadSystems.com
_______________________________________________
gnucash-user mailing list
gnucash-user@gnucash.org
To update your subscription preferences or to unsubscribe:
https://lists.gnucash.org/mailman/listinfo/gnucash-user
If you are using Nabble or Gmane, please see 
https://wiki.gnucash.org/wiki/Mailing_Lists for more information.
-----
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.

Reply via email to