Yeah, that seems to be the issue. Did you manage to update the so that it is working?
I really tried but didn't get it to work. It just returned

AttributeError: 'module' object has no attribute 'ServiceAccountCredentials'

I haven't been trying more though since it was working on my current 
But it would be nice to be able to find a solution to this.


On Thursday, October 13, 2016 at 11:48:45 PM UTC+2, Levi Baber wrote:
> I'm running into a similar issue.  I think the only reason the example 
> worked for you on Linux is because the is specifically pulling 
> down version 1.3.2 of the oauth2client from github. I have tried using the 
> latest earthengine-api available from pip, and the latest google-app-engine 
> SDK and google-cloud-sdk and the problem is there as well. 
> From what I can tell, the earth-engine is using the old method 
> and needs to be updated to use the new ServiceAccountCredentials method. 
> On Monday, October 3, 2016 at 7:55:00 AM UTC-5, Michael Johansson wrote:
>> I have now tried the example in a Linux environment (Ubuntu 16.04.1 LTS).
>> After installing all required prerequisites to just get the environment 
>> up and running, I ran the and the examples ran pretty smoothly 
>> thereafter. This does tell me that something in the Earth Engine API as of 
>> now is not really working well in windows, or at least is a bit convoluted 
>> to get running.
>> I did discuss the issue on the GIT repository issue tracker but didn't 
>> really get closer to a solution. 
>> I will post about this in the Earth Engine Developers group.
>> //Best regards
>> Michael
>> On Friday, September 23, 2016 at 3:52:50 PM UTC+2, Michael Johansson 
>> wrote:
>>> Thank you for the reply. I will file an issue there and keep you updated 
>>> with what I find out or learn.
>>> I also tried another server example 
>>> <>, 
>>> I got the exact same error. Since I am using the same earth engine library, 
>>> it might be an issue with that API. When I know more I will post in the 
>>> earth engine developers forum as well.
>>> Because as of now I feel that I am guessing a lot :)
>>> During the weekend I will also try to run the examples in a linux 
>>> environment, if it is a Earth engine API issue, I guess it might not work 
>>> there as well.
>>> Best regards
>>> //Michael
>>> On Friday, September 23, 2016 at 1:49:02 AM UTC+2, Nick (Cloud Platform 
>>> Support) wrote:
>>>> Hey Michael,
>>>> It appears you found an issue in the "trendy lights" demo. You should 
>>>> file an issue on the github repo and link this thread for context. It 
>>>> seems 
>>>> you did indeed find the source of the issue in the changed name of the 
>>>> function.
>>>> Cheers,
>>>> Nick
>>>> Cloud Platform Community Support
>>>> On Wednesday, September 21, 2016 at 10:05:44 AM UTC-4, Michael 
>>>> Johansson wrote:
>>>>> *Update:*
>>>>> This seems to be an issue with how the authentication is done in the 
>>>>> example. It seems that it has changed since the example was written.
>>>>> As a newcomer to the App engine, this is pretty confusing to wrap my 
>>>>> head around. 
>>>>> Maybe it is really simple. I have at least been trying to figure out 
>>>>> how I can change the code in
>>>>> But instead of :
>>>>> AttributeError: 'module' object has no attribute 
>>>>> 'SignedJwtAssertionCredentials'
>>>>> I get: 
>>>>> AttributeError: 'module' object has no attribute 
>>>>> 'ServiceAccountCredentials'
>>>>> What I changed was: 
>>>>>  if key_file:
>>>>>     key_data = open(key_file, 'rb').read()
>>>>>   return oauth2client.ServiceAccountCredentials(
>>>>>       email, key_data, oauth.SCOPE)
>>>>> Before it was:
>>>>>   if key_file:
>>>>>     key_data = open(key_file, 'rb').read()
>>>>>   return oauth2client.client.SignedJwtAssertionCredentials(
>>>>>     email, key_data, oauth.SCOPE)
>>>>> I was trying to follow recommendations from this 
>>>>> <>
>>>>> on github 
>>>>> I've also been trying to understand the changes as they are explained 
>>>>> here:
>>>>> Maybe I'm way off here and the change is a pretty naive try to solve 
>>>>> this...
>>>>> //Michael

You received this message because you are subscribed to the Google Groups 
"Google App Engine" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
To post to this group, send email to
Visit this group at
To view this discussion on the web visit
For more options, visit

Reply via email to