On Tue, Mar 16, 2010 at 11:54 AM, Eric Ayers <[email protected]> wrote:
> Something is screwy with riedvelt, and I can't leave a comment on
> XSTemplate.js
>
> My comment isn't really about your patch in particular, but the patterns we
> are using in the linker templates. I wish that stanzas of code common to
> many linkers, like the calling of __gwtStatsEvent() could be extracted and
> put into the template with variable substitution. For example, adding the
> sessionId field to the event works fine here, but there are several linkers
> outside of GWT that will need to be updated to get the same fix.
>
Yes. Indeed, this fix originally went into the iframe linker and it was
overlooked for the cross-site linker. Using more templating should help us
not have to duplicate code so much.
I was thinking in the short term to pull out computeScriptBase and
processMetas into their own file. Code that wants to pull it in could
insert COMPUTE_SCRIPT_BASE or PROCESS_METAS at the place it should go. As
well, the code can then be tested more conveniently.
Perhaps, though, we may as well define a general INCLUDE("processMetas.js")
?
Lex
--
http://groups.google.com/group/Google-Web-Toolkit-Contributors