On Tue, Mar 16, 2010 at 1:47 PM, Lex Spoon <[email protected]> wrote:

> Yes.  Indeed, this fix originally went into the iframe linker and it was
> overlooked for the cross-site linker.  Using more templating should help us
> not have to duplicate code so much.
>
> I was thinking in the short term to pull out computeScriptBase and
> processMetas into their own file.  Code that wants to pull it in could
> insert COMPUTE_SCRIPT_BASE or PROCESS_METAS at the place it should go.  As
> well, the code can then be tested more conveniently.
>
> Perhaps, though, we may as well define a general INCLUDE("processMetas.js")
> ?
>

I think everyone agrees that we need some sort of approach to reduce code
duplication here (and I think a similar problem exists in property providers
-- right now if I want to slightly extend a property provider I have to cut
and paste it).  I think there are differences on exactly how far we should
go, and since everybody has more than enough to do already nobody has
grabbed the horns.

-- 
John A. Tamplin
Software Engineer (GWT), Google

-- 
http://groups.google.com/group/Google-Web-Toolkit-Contributors

Reply via email to