I like the new overloads with String arguments.  I've submitted them
before and had them bounce ("why do we need them?"), but they really do
shorten code.

Changing jprogram. to JProgram. seems not all that helpful, but if you
really want it, fine.  It just seems like the kind of thing that is
going to toggle back and forth a lot over time.

If you want to look at node-building, what would really help is to have
a node-building interface that has an instance method for every kind of
node.  This would make it easy to remember how to build nodes, because
you'd always just go to that interface.  It can also help us disentangle
the dependencies of the implementation.  JProgram is a very heavy
dependency, and probably some things that currently depend on JProgram
could instead depend on a node builder.

http://gwt-code-reviews.appspot.com/304801/show

--
http://groups.google.com/group/Google-Web-Toolkit-Contributors

To unsubscribe, reply using "remove me" as the subject.

Reply via email to