Hi
i am working on date pickers for domino-ui, mean while i found that in 
order to support different locales in the date picker i need the 
DateTimeFormat information for each locale, gwt in the other hand has a 
decent support for datetime format informtion, so instead of adding my own 
implementation and after a small discussion with colin i decided to use gwt 
DatetimeFormat implementation, but to avoid adding dependency on gwt-user i 
decided to work in a partial porting of the gwt datetime formats, i am 
modifing the cldr-import tool to generate the sources into there own 
module/jar with the new package name org.gwtproject.X to make sure that 
later they can be used with the rest of the i18n porting, also i am 
migrating the gwt cldr-importer from ant to gradle, the new one will reduce 
the manual steps to generate new cldr classes, so instead of checkout, 
build, copy, import, it will be a single commad to acheive it all. i will 
make the repository avialble for review and feedback on github very soon 
when i am done.

my question here is 
for the new cldr data generator i should use
groupId : org.gwtproject.tools, artifactId : gwt-cldr-importer does this 
look right?

On Saturday, March 24, 2018 at 11:30:10 AM UTC+2, Mincong Huang wrote:
>
> Hi,
>
> I'd like to have a clarification about the naming convention for ported 
> GWT modules. Because I'm porting the module `gwt-safecss` and 
> `gwt-animation`. When I go to Vertispan repository [1], the available 
> modules do not use the same rule for the group ID and artifact ID. This is 
> a pain when you reference them as dependencies. Here're 5 rules that I 
> found.
>
> *Rule 1:*
> Use "org.gwtproject" + module name as group id; module name with "gwt-" 
> prefix as artifact id. This rule is used by `gwt-http`:
>
>     GROUP_ID:    org.gwtproject.$MODULE
>     ARTIFACT_ID: gwt-$MODULE
>
> *Rule 2:*
> Use "org.gwtproject" + module name as group id; module name without "gwt-" 
> prefix as artifact id. This rule is used by `gwt-event`, `gwt-place`, 
> `gwt-safehtml`, `gwt-storage`, `gwt-timer`:
>
>     GROUP_ID:    org.gwtproject.$MODULE
>     ARTIFACT_ID: $MODULE
>
> *Rule 3:*
> Use "org.gwtproject" as group id; module name with "gwt-" prefix as 
> artifact id. This rule is used by `gwt-xhr`:
>
>     GROUP_ID:    org.gwtproject
>     ARTIFACT_ID: gwt-$MODULE
>
> *Rule 4:*
> Use "org.gwtproject" as group id; module name without "gwt-" prefix as 
> artifact id. This rule is used by `gwt-json`, `gwt-typedarrays`, `gwt-xml`, 
> `gwt-xhr`:
>
>     GROUP_ID:    org.gwtproject
>     ARTIFACT_ID: $MODULE
>
> *Rule 5:*
> Other rules: `gwt-window`, `gwt-history`.
>
> I suggest we apply rule 4 to all the modules. It means always using 
> "org.gwtproject` as group id, and use `gwt-` + module name as artifact id. 
> There're several benefits. It helps people to find all the artifacts via 
> the same group id. It also keeps consistency for the generated JAR files: 
> each of them contains a "gwt-" prefix, thus they are GWT artifacts.
>
> Cheers,
> Mincong Huang
>
> [1]: https://repo.vertispan.com/gwt-snapshot/
>

-- 
You received this message because you are subscribed to the Google Groups "GWT 
Contributors" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to google-web-toolkit-contributors+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/google-web-toolkit-contributors/43162b69-d854-4e46-b975-9ba7352a9b36%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to