On 18/10/16 17:28, James Duffy wrote:
On 18 October 2016 at 16:17, Moritz Lennert
<mlenn...@club.worldonline.be <mailto:mlenn...@club.worldonline.be>> wrote:

    On 18/10/16 14:27, James Duffy wrote:

        Hello,

        I'm using GRASS 7.0.4 on the OSGeoLive pre-built operating system. I
        have installed the addon 'i.segment.stats' to use with my output
        from
        'i.segment.uspo'.

        When selecting the 'rasters' input for this tool, I choose the
        original
        layers that were used to create the segmented map in the first
        place.
        Upon execution of 'i.segment.stats', i get the following error:

        Element type should be "cell" and not "raster.


    The above message is just a warning and should not keep the module
    from working. I just fixed this (r69700), so try reinstalling
    i.segment.stats.


Ok thank you, have reinstalled and the message no longer appears.



        The tool does not continue and outputs a blank .csv file.

        Any help solving this would be much appreciated.


    Could you send us the command line used (you can get that by pushing
    the 'Copy' button in the GUI of the module or through the command
    history in the GUI 'command console')


i.segment.stats --overwrite --verbose
map=angle_seg_uspo_angle_region_1_rank1@angle1
rasters=angle_ortho.1@angle1 raster_statistics=min,max,mean,stddev,sum
csvfile=/home/jd/Wales_GRASS/isegstats_gp_test separator=comma

With this command, the output .csv is still empty apart from the headers.

Are you sure the region is set to angle_seg_uspo_angle_region_1_rank1 ? I.e.:

g.region rast=angle_seg_uspo_angle_region_1_rank1

What do

g.region -p
and
r.info angle_seg_uspo_angle_region_1_rank1

give you ?

Moritz
_______________________________________________
grass-user mailing list
grass-user@lists.osgeo.org
http://lists.osgeo.org/mailman/listinfo/grass-user

Reply via email to