On 13-04-2018 03:58, Shawn Heisey wrote:
I have a script on my system that I use to handle compiling and installing a new haproxy version.  That script has "EXTRA=haproxy-systemd-wrapper"on the line that does the install.


It looks like that's no longer part of haproxy, and that the systemd service definition (included in contrib) just calls haproxy directly. USE_SYSTEMD must be set on the compile command when using the contrib systemd script, and the systemd development library must be present.

But I don't see anything in CHANGELOG or README that talks about it at all, and definitely nothing saying that the wrapper has been removed, and nothing mentioning the new compile requirements.

Was there somewhere else that I should have looked for information about how to get 1.8 working with systemd?

Shawn,

I ran into the same thing a while back. I don't know what OS you are using, but you might want to check these SPEC files I wrote for inspiratoin. I'm no expert packager, but it works for me:

https://github.com/AxisNL/haproxy-rpmbuild

I upload the packages I build here: https://haproxy.hongens.nl



--
--

met vriendelijke groet,

Angelo Höngens

Reply via email to