> On 2012-01-20 22:43:04, Ashutosh Chauhan wrote: > > Is there an easy way either in unit tests or e2e tests for failure > > scenarios. It will be great if we have coverage for abortJob() methods > > which aborts ZK transactions.
We can create an M/R job which intentionally fails after a number of writes. If we were only to do one, testing in e2e would probably be better since behavior might be different in minicluster. > On 2012-01-20 22:43:04, Ashutosh Chauhan wrote: > > storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseBaseOutputStorageDriver.java, > > line 91 > > <https://reviews.apache.org/r/3291/diff/2/?file=69524#file69524line91> > > > > qualifiedTableName sounds better name to me. sure, either sound ok to me. > On 2012-01-20 22:43:04, Ashutosh Chauhan wrote: > > storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseConstants.java, > > line 30 > > <https://reviews.apache.org/r/3291/diff/2/?file=69527#file69527line30> > > > > Word property is redundant in variable name. Get rid of it. This also > > holds for other variable names in this file. The prefix is used to define what the constant is used for. In this case it's for table/jobInfo property. We could have a MAPRED prefix for specifying properties directly in the jobcontext. If you feel strongly about removing this for all the constants we could discuss that in a separate jira? > On 2012-01-20 22:43:04, Ashutosh Chauhan wrote: > > storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseBaseOutputStorageDriver.java, > > lines 118-120 > > <https://reviews.apache.org/r/3291/diff/2/?file=69524#file69524line118> > > > > Since we are already serializing the full Txn object, there is no need > > to serialize rev number seperately. Rev number can be fetched from > > serialized Txn object. Sure, streamlining sounds good. - Francis ----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/3291/#review4506 ----------------------------------------------------------- On 2012-01-18 06:13:50, Francis Liu wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/3291/ > ----------------------------------------------------------- > > (Updated 2012-01-18 06:13:50) > > > Review request for hcatalog, Ashutosh Chauhan, Vandana Ayyalasomayajula, and > David Capwell. > > > Summary > ------- > > Integrated write transactions in HBase OSD. > > > This addresses bug hcatalog-192. > https://issues.apache.org/jira/browse/hcatalog-192 > > > Diffs > ----- > > > storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseBaseOutputStorageDriver.java > 8ba0e8a > > storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseBulkOutputFormat.java > 004e3df > > storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseBulkOutputStorageDriver.java > bdc06ce > > storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseConstants.java > b3b90ab > > storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseDirectOutputFormat.java > 706c911 > > storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseHCatStorageHandler.java > 99b92b1 > > storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseSerDeResultConverter.java > 5eac5b8 > > storage-drivers/hbase/src/test/org/apache/hcatalog/hbase/TestHBaseBulkOutputStorageDriver.java > 57b4928 > > storage-drivers/hbase/src/test/org/apache/hcatalog/hbase/TestHBaseDirectOutputStorageDriver.java > b7182fd > > storage-drivers/hbase/src/test/org/apache/hcatalog/hbase/TestHBaseSerDeResultConverter.java > d6215ed > > Diff: https://reviews.apache.org/r/3291/diff > > > Testing > ------- > > Updated units tests, also had to remove two that were no longer needed. All > tests passed. > > > Thanks, > > Francis > >
