[ 
https://issues.apache.org/jira/browse/HDFS-9940?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15196566#comment-15196566
 ] 

Yongjun Zhang commented on HDFS-9940:
-------------------------------------

Hi Guys,

I wonder if this can be a balancer config only, and we don't need to set at 
datanode side. That is, when balancer starts, it reads this config, and it 
tells NN about this config, then NN can tell each datanode about this config as 
a piggyback of heartbeat response. This is similar like how 

{{final static int DNA_BALANCERBANDWIDTHUPDATE = 8; // update balancer 
bandwidth}}

works.

If what I'm proposing here works, then we can just use 
{{dfs.balancer.max.concurrent.moves}}, and user doesn't need to set DN. 

Thanks.



> Rename dfs.balancer.max.concurrent.moves to avoid confusion
> -----------------------------------------------------------
>
>                 Key: HDFS-9940
>                 URL: https://issues.apache.org/jira/browse/HDFS-9940
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: balancer & mover
>    Affects Versions: 2.6.0
>            Reporter: John Zhuge
>            Assignee: John Zhuge
>            Priority: Minor
>              Labels: supportability
>             Fix For: 2.8.0
>
>
> It is very confusing for both Balancer and Datanode to use the same property 
> {{dfs.datanode.balance.max.concurrent.moves}}. It is especially so for the 
> Balancer because the property has "datanode" in the name string. Many 
> customers forget to set the property for the Balancer.
> Change the Balancer to use a new property 
> {{dfs.balancer.max.concurrent.moves}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to