[
https://issues.apache.org/jira/browse/HDFS-9940?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15196705#comment-15196705
]
John Zhuge commented on HDFS-9940:
----------------------------------
[~yzhangal], great idea if we don't have to manually config each DN for
rebalance. Since we already have {{hdfs dfsadmin -setBalancerBandwidth}}, we
have 2 choices.
1) Add {{hdfs dfsadmin -setBalancerConcurrentMoves}} and {{hdfs dfsadmin
-getBalancerConcurrentMoves}}
2) Balancer automatically calls Namenode API {{setBalancerBandwidth}} and newly
added {{setBalancerConcurrentMoves}} based on config values (or even command
options). Obsolete {{hdfs dfsadmin -setBalancerBandwidth}} and {{hdfs dfsadmin
-getBalancerBandwidth}}.
> Rename dfs.balancer.max.concurrent.moves to avoid confusion
> -----------------------------------------------------------
>
> Key: HDFS-9940
> URL: https://issues.apache.org/jira/browse/HDFS-9940
> Project: Hadoop HDFS
> Issue Type: Improvement
> Components: balancer & mover
> Affects Versions: 2.6.0
> Reporter: John Zhuge
> Assignee: John Zhuge
> Priority: Minor
> Labels: supportability
> Fix For: 2.8.0
>
>
> It is very confusing for both Balancer and Datanode to use the same property
> {{dfs.datanode.balance.max.concurrent.moves}}. It is especially so for the
> Balancer because the property has "datanode" in the name string. Many
> customers forget to set the property for the Balancer.
> Change the Balancer to use a new property
> {{dfs.balancer.max.concurrent.moves}}.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)