[
https://issues.apache.org/jira/browse/HDFS-9940?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15197887#comment-15197887
]
Tsz Wo Nicholas Sze commented on HDFS-9940:
-------------------------------------------
> ... I wonder if this can be a balancer config only, and we don't need to set
> at datanode side ...
The datanode side conf is for protecting the cluster being abused by Balancer.
So we need to keep it.
> Add hdfs dfsadmin -setBalancerConcurrentMoves ...
It may not work well since setting concurrent-move currently require datanode
restart. It would be great if restart is not required but it seems not
straightforward to do.
> Rename dfs.balancer.max.concurrent.moves to avoid confusion
> -----------------------------------------------------------
>
> Key: HDFS-9940
> URL: https://issues.apache.org/jira/browse/HDFS-9940
> Project: Hadoop HDFS
> Issue Type: Improvement
> Components: balancer & mover
> Affects Versions: 2.6.0
> Reporter: John Zhuge
> Assignee: John Zhuge
> Priority: Minor
> Labels: supportability
> Fix For: 2.8.0
>
>
> It is very confusing for both Balancer and Datanode to use the same property
> {{dfs.datanode.balance.max.concurrent.moves}}. It is especially so for the
> Balancer because the property has "datanode" in the name string. Many
> customers forget to set the property for the Balancer.
> Change the Balancer to use a new property
> {{dfs.balancer.max.concurrent.moves}}.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)