[ 
https://issues.apache.org/jira/browse/HDFS-14922?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16968005#comment-16968005
 ] 

Íñigo Goiri commented on HDFS-14922:
------------------------------------

I meant the full javadoc:
{code}
/**
 * Log that a snapshot is created.
 * @param snapRoot Root of the snapshot.
 * @param snapName Name of the snapshot.
 * @param toLogRpcIds If it is logging RPC ids.
 * @param mtime The snapshot creation time set by Time.now().
 */
void logCreateSnapshot(String snapRoot, String snapName, boolean toLogRpcIds,
    long mtime) {
{code}

It doesn't hurt to improve the readability of the existing code.
BTW, even though {{setSnapshotMTime()}} is package protected, we should also 
add the javadoc there.

> On StartUp , Snapshot modification time got changed
> ---------------------------------------------------
>
>                 Key: HDFS-14922
>                 URL: https://issues.apache.org/jira/browse/HDFS-14922
>             Project: Hadoop HDFS
>          Issue Type: Bug
>            Reporter: hemanthboyina
>            Assignee: hemanthboyina
>            Priority: Major
>         Attachments: HDFS-14922.001.patch, HDFS-14922.002.patch, 
> HDFS-14922.003.patch, HDFS-14922.004.patch
>
>
> Snapshot modification time got changed on namenode restart



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to