Robert, thanks for doing so much work to verify what Ashis is seeing.

That said, I am still not seeing this problem. My working notion is that it is a problem that somehow got fixed while I was doing some other work a few months ago.

This morning, I prepared and uploaded a new installer package as a pre-release of the upcoming version. Here's the direct link.

If one or both of you could install this and let me know if the problem persists, I would be grateful.

I did uncover a bunch of of problems with Demeter's crystallography bits while I was working on,

I don't really see the value of sifting through all that work to figure out what had an impact on Ashis' issue. If the newer code works -- that seems good enough to me.


On 04/03/2017 06:08 PM, Robert Gordon wrote:
Hi Ashis,

I can reproduce what you are seeing.
I exported the atoms.inp's for your two structures.

If I import TAA first and run atoms, it looks ok. I then import TPA and
run - ok.
I re-run Atoms on TAA, it changes.

In fact, from a clean start of Artemis 0.9.25 on win10pro/AMD64, if I
import TAA's inp and run it, it looks ok.
I added it again, it still looks ok, even if I re-run Atoms. I add TPA
and run it, it looks ok, but if I rerun
either of the TAA, they have changed. Changes persist even if TPA discarded.

From another clean start of Artemis, I import TAA and run Atoms - ok.
I import a different inp (ni metal) and run it - ok. Re-run TAA and it
is ok.

From another clean start, I import Ni metal and run it...ok
Import TPA and run it...ok...Rerun Ni and Ni changes...definite symmetry
This symmetry change persists even if I discard TPA and import another
copy of Ni.

Clean start, import Ni and run, then import another Rhombohedral
structure (B phase)
and same problem...symmetry changes and I don't seem to be able to get
it to change back,
even when I deliberately change the space group for Ni and it is the
only calculation remaining.

Clean start...import Ni...ok....add rhombohedral structure (B) but don't
run it..rerun Ni and Ni changes.

Clean start, import hexagonal structure (in P6)...ok...import
Ni...ok....change hex to Rhomb indexed on hex
and Ni changes when rerun...

So...problem seems to be related to the symmetry - stuck in Rhombohedral
once a R-structure
is added...or symmetry changed to R.

Haven't tried on Linux yet.


On 4/3/2017 1:46 PM, Ashis Biswas wrote:

Dear Bruce,

Sorry for late reply. I wanted to test in another computer before
replying. Unfortunately, this time also I got different results for
TAA. Following is the click by click description of what I am doing to
arrive in this state:

Double click on “Atemis” shortcut on desktop => Click “add” in the
Feff calculation tab => Open “TPP” Atom input file from desktop=>
Click “Run Atom” => Click “Run Feff” => Click “add” in the Feff
calculation tab => Open “TAA” CIF file from desktop=> Click “Run Atom”
=> Click “Run Feff”

I am sorry for killing your time. Actually, I am very much new in this
field and therefore I really want to be sure that what I am doing for
importing object for feff calculation is correct or not. Thank you
very much for your support.

With regards,


On 2017-03-28 16:13, Bruce Ravel wrote:
On 03/27/2017 11:02 AM, Ashis Biswas wrote:
Thank you very much for your reply. Here I am attaching two Artemis
projects files (TAA_TPA and TPA_TAA), named according to their order of
import. In my computer the paths for *TAA* are different in two project
files. For example, i) in TAA_TPA project the Reff for three single
scattering paths of O (@O1.1; @O3.1, and @O5.1) are different to
that in
TPA_TAA project, ii) the single scattering path @C5.1 (path number
6) at
Reff of 2.682 A0 in TAA_TPA project is missing in TPA_TAA project, and
so on.

I am also attaching the papers from where the coordinates for TAA and
TPA are obtained: TAA (Kamenar et al., 1993: tables 1 & 2; Fig. 1) and
TPA (Pappalardo et al., 1983: Table 1; Fig. 1).

I agree that the TPA_TAA.fpj project file that you sent me has
incorrect data in the Feff tab for TAA.

I have not, however, been able to reproduce that here.  And not for
want of trying -- I spent the last half hour trying to find a way to
replicate what you are showing in the TPA_TAA file.  Regardless of
the order in which I import the two structures and regardless of
whether I have discarded and reimported Feff calculations, when I
click the "Run Atoms" button on the TAA cif file, I /always/ get the
structure from Table 4 in the Kamenar paper.  I cannot reproduce the
Feff tab that you show in your TPA_TAA project file.

I have no idea how you got into the state you show in the TPA_TAA
project.  It is clear that something went awry, but I don't know if
it is an error of the program or of the user.  I can't fix a problem
I can't observe.

I understand that this is not the answer you were looking for.  I am
simply not seeing the problem you are reporting.


Ifeffit mailing list

Ifeffit mailing list

 Bruce Ravel  ------------------------------------

 National Institute of Standards and Technology
 Synchrotron Science Group at NSLS-II
 Building 743, Room 114
 Upton NY, 11973

Ifeffit mailing list

Reply via email to