Chris Wilson <ch...@chris-wilson.co.uk> writes:
> Quoting Joonas Lahtinen (2018-02-09 07:48:21)
>> Quoting Chris Wilson (2018-02-09 01:11:34)
>> > We want to de-emphasize the link between the request (dependency,
>> > execution and fence tracking) from GEM and so rename the struct from
>> > drm_i915_gem_request to i915_request. That is we may implement the GEM
>> > user interface on top of requests, but they are an abstraction for
>> > tracking execution rather than an implementation detail of GEM. (Since
>> > they are not tied to HW, we keep the i915 prefix as opposed to intel.)
>> There are also some req -> rq renames in addition to function renames.
>> If we're touching this much code, would it make sense to at least
>> consolidate the parameter names into "request" or "req" when touched
> Never req. I always used rq in the pre-existing code as shorthand, and
> request otherwise.
One could argue that rq is too short but it is so fundamental concept
in gem code that obviousess/uniqueness is usually guaranteed.
My vote will go to 'rq' too.
Intel-gfx mailing list