> -----Original Message-----
> From: Manna, Animesh <[email protected]>
> Sent: Tuesday, June 16, 2026 1:33 AM
> To: [email protected]; [email protected]
> Cc: Shankar, Uma <[email protected]>; Dibin Moolakadan Subrahmanian
> <[email protected]>; [email protected];
> Nikula, Jani <[email protected]>; Manna, Animesh
> <[email protected]>
> Subject: [PATCH v9 08/22] drm/i915/display: Rename cpu_transcoder parameter
> to transcoder in LRR path
> 
> intel_set_transcoder_timings_lrr() now takes the target transcoder as an 
> explicit
> argument rather than implicitly using crtc_state->cpu_transcoder, so the
> parameter name 'cpu_transcoder' is misleading. Rename it to plain 
> 'transcoder' to
> reflect that any transcoder may be programmed.
> 
> No functional change.

Looks Good to me.
Reviewed-by: Uma Shankar <[email protected]>

> Signed-off-by: Animesh Manna <[email protected]>
> ---
>  drivers/gpu/drm/i915/display/intel_display.c | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)
> 
> diff --git a/drivers/gpu/drm/i915/display/intel_display.c
> b/drivers/gpu/drm/i915/display/intel_display.c
> index 049038742517..edb9acb1da5c 100644
> --- a/drivers/gpu/drm/i915/display/intel_display.c
> +++ b/drivers/gpu/drm/i915/display/intel_display.c
> @@ -2778,13 +2778,13 @@ static void intel_set_transcoder_timings(const struct
> intel_crtc_state *crtc_sta  }
> 
>  static void intel_set_transcoder_timings_lrr(const struct intel_crtc_state
> *crtc_state,
> -                                          enum transcoder cpu_transcoder)
> +                                          enum transcoder transcoder)
>  {
>       struct intel_display *display = to_intel_display(crtc_state);
>       const struct drm_display_mode *adjusted_mode = &crtc_state-
> >hw.adjusted_mode;
>       u32 crtc_vdisplay, crtc_vtotal, crtc_vblank_start, crtc_vblank_end;
> 
> -     drm_WARN_ON(display->drm, transcoder_is_dsi(cpu_transcoder));
> +     drm_WARN_ON(display->drm, transcoder_is_dsi(transcoder));
> 
>       crtc_vdisplay = adjusted_mode->crtc_vdisplay;
>       crtc_vtotal = adjusted_mode->crtc_vtotal; @@ -2799,7 +2799,7 @@
> static void intel_set_transcoder_timings_lrr(const struct intel_crtc_state 
> *crtc
> 
>       if (DISPLAY_VER(display) >= 13) {
>               intel_de_write(display,
> -                            TRANS_SET_CONTEXT_LATENCY(display,
> cpu_transcoder),
> +                            TRANS_SET_CONTEXT_LATENCY(display,
> transcoder),
>                              crtc_state->set_context_latency);
> 
>               /*
> @@ -2816,7 +2816,7 @@ static void intel_set_transcoder_timings_lrr(const
> struct intel_crtc_state *crtc
>        * The hardware actually ignores TRANS_VBLANK.VBLANK_END in DP
> mode.
>        * But let's write it anyway to keep the state checker happy.
>        */
> -     intel_de_write(display, TRANS_VBLANK(display, cpu_transcoder),
> +     intel_de_write(display, TRANS_VBLANK(display, transcoder),
>                      VBLANK_START(crtc_vblank_start - 1) |
>                      VBLANK_END(crtc_vblank_end - 1));
> 
> @@ -2826,7 +2826,7 @@ static void intel_set_transcoder_timings_lrr(const
> struct intel_crtc_state *crtc
>        * using the VRR timing generator!). Thus updating TRANS_VSYNC
>        * here seems fine even if it isn't double buffered.
>        */
> -     intel_de_write(display, TRANS_VSYNC(display, cpu_transcoder),
> +     intel_de_write(display, TRANS_VSYNC(display, transcoder),
>                      VSYNC_START(adjusted_mode->crtc_vsync_start - 1) |
>                      VSYNC_END(adjusted_mode->crtc_vsync_end - 1));
>       /*
> @@ -2842,7 +2842,7 @@ static void intel_set_transcoder_timings_lrr(const
> struct intel_crtc_state *crtc
>        * The double buffer latch point for TRANS_VTOTAL
>        * is the transcoder's undelayed vblank.
>        */
> -     intel_de_write(display, TRANS_VTOTAL(display, cpu_transcoder),
> +     intel_de_write(display, TRANS_VTOTAL(display, transcoder),
>                      VACTIVE(crtc_vdisplay - 1) |
>                      VTOTAL(crtc_vtotal - 1));
>  }
> --
> 2.29.0

Reply via email to