Regarding variable parameter names; if the syntax was:

function foo( $firstParameter ) { ... }
foo( $firstParameter=> 'foo' );

Then the double-dollar syntax would seem the obvious choice to me:

function foo( $firstParameter ) { ... }
$param = 'firstParameter';
foo( $$param => 'whatever' );

Which is no less readable than anywhere else the double-dollar is
allowed...  :-p

--G

Reply via email to