[
https://issues.apache.org/jira/browse/CAMEL-13086?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16748021#comment-16748021
]
Claus Ibsen commented on CAMEL-13086:
-------------------------------------
The rule of thumb for these endXXX is to think them as end current block and go
back to XXX.
So endChoice is to go back to choice, not ending choice.
> Java DSL: Rename "endChoice" to "endWhen"
> -----------------------------------------
>
> Key: CAMEL-13086
> URL: https://issues.apache.org/jira/browse/CAMEL-13086
> Project: Camel
> Issue Type: Wish
> Components: camel-core
> Reporter: Peter Keller
> Priority: Major
> Fix For: 3.0.0
>
>
> Java DSL: Rename {{endChoice}} to {{endWhen}} as {{endChoice}} actually ends
> a {{when}} condition.
> I am aware that this will break current routes. Nevertheless I wanted to
> bring this issue to discussion as {{endChoice}} isn't obvious for beginners
> that learn the framework.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)