[
https://issues.apache.org/jira/browse/CAMEL-13086?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16752388#comment-16752388
]
Tanner Gibson commented on CAMEL-13086:
---------------------------------------
This was a cause of a bug in a pr I reviewed and spent an excessive amount of
time testing and reading documentation to determine the cause of the issue. I
understand the choice made but it is not at all obvious when using it. It's a
similar issue as timestamp is MSSQL you miss use it once and then you learn but
it takes a really annoying bug and amount of time to realize that you're using
something wrong because the name is miss leading.
> Java DSL: Rename "endChoice" to "endWhen"
> -----------------------------------------
>
> Key: CAMEL-13086
> URL: https://issues.apache.org/jira/browse/CAMEL-13086
> Project: Camel
> Issue Type: Wish
> Components: camel-core
> Reporter: Peter Keller
> Priority: Major
> Fix For: 3.0.0
>
>
> Java DSL: Rename {{endChoice}} to {{endWhen}} as {{endChoice}} actually ends
> a {{when}} condition.
> I am aware that this will break current routes. Nevertheless I wanted to
> bring this issue to discussion as {{endChoice}} isn't obvious for beginners
> that learn the framework.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)