[
https://issues.apache.org/jira/browse/CAMEL-13086?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16811854#comment-16811854
]
Darius Cooper commented on CAMEL-13086:
---------------------------------------
[~drekbour] is your suggestion to:
* Add endWhen() as a synonym to today's endChoice()
* Allowing users to switch to the new term
* While, allowing existing programs to continue working
> Java DSL: Rename "endChoice" to "endWhen"
> -----------------------------------------
>
> Key: CAMEL-13086
> URL: https://issues.apache.org/jira/browse/CAMEL-13086
> Project: Camel
> Issue Type: Wish
> Components: camel-core
> Reporter: Peter Keller
> Priority: Major
> Fix For: 3.0.0
>
>
> Java DSL: Rename {{endChoice}} to {{endWhen}} as {{endChoice}} actually ends
> a {{when}} condition.
> I am aware that this will break current routes. Nevertheless I wanted to
> bring this issue to discussion as {{endChoice}} isn't obvious for beginners
> that learn the framework.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)