[ 
https://issues.apache.org/jira/browse/FLINK-6805?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16119971#comment-16119971
 ] 

Michael Fong commented on FLINK-6805:
-------------------------------------

All other flink libraries depends on 4.0.27, except flink-connect-cassandra 
seems to have a newer Netty4 dependency of version 4.0.33 using default scope 
'compile'.

Resolved dep tree:
[INFO] org.apache.flink:flink-connector-cassandra_2.11:jar:1.4-SNAPSHOT
[INFO] +- 
{color:red}com.datastax.cassandra:cassandra-driver-core:jar:3.0.{color}0:compile
[INFO] |  \- io.netty:netty-handler:jar:4.0.33.Final:compile
[INFO] |     +- io.netty:netty-buffer:jar:4.0.33.Final:compile
[INFO] |     |  \- io.netty:netty-common:jar:4.0.33.Final:compile
[INFO] |     +- io.netty:netty-transport:jar:4.0.33.Final:compile
[INFO] |     |  \- (io.netty:netty-buffer:jar:4.0.33.Final:compile - omitted 
for duplicate)
[INFO] |     \- io.netty:netty-codec:jar:4.0.33.Final:compile
[INFO] |        \- (io.netty:netty-transport:jar:4.0.33.Final:compile - omitted 
for duplicate)
[INFO] +- org.apache.flink:flink-runtime_2.11:test-jar:tests:1.4-SNAPSHOT:test
[INFO] |  +- com.data-artisans:flakka-remote_2.11:jar:2.3-custom:test
[INFO] |  |  \- io.netty:netty:jar:3.8.0.Final:test
[INFO] |  \- org.apache.zookeeper:zookeeper:jar:3.4.10:test
[INFO] |     \- (io.netty:netty:jar:3.10.5.Final:test - omitted for conflict 
with 3.8.0.Final)
[INFO] \- org.apache.cassandra:cassandra-all:jar:2.2.5:test
[INFO]    \- io.netty:netty-all:jar:4.0.23.Final:test

However, I am not sure which version would be picked up at runtime, since Flink 
seems to wrap all classes (libraries included) in a fat jar at runtime. In 
addition, there is the FLINK-7013 that intends to organize all classes imported 
from netty. 

Hi, [~Zentol], could you please share some insight to this tickets? I would 
love to help improve on this if there is any need to update maven dependencies. 

Regards,

Michael Fong

> Flink Cassandra connector dependency on Netty disagrees with Flink
> ------------------------------------------------------------------
>
>                 Key: FLINK-6805
>                 URL: https://issues.apache.org/jira/browse/FLINK-6805
>             Project: Flink
>          Issue Type: Bug
>          Components: Cassandra Connector
>    Affects Versions: 1.3.0, 1.2.1
>            Reporter: Shannon Carey
>
> The Flink Cassandra connector has a dependency on Netty libraries (via 
> promotion of transitive dependencies by the Maven shade plugin) at version 
> 4.0.33.Final, which disagrees with the version included in Flink of 
> 4.0.27.Final which is included & managed by the parent POM via dependency on 
> netty-all.
> Due to use of netty-all, the dependency management doesn't take effect on the 
> individual libraries such as netty-handler, netty-codec, etc.
> I suggest that dependency management of Netty should be added for all Netty 
> libraries individually (netty-handler, etc.) so that all Flink modules use 
> the same version, and similarly I suggest that exclusions be added to the 
> quickstart example POM for the individual Netty libraries so that fat JARs 
> don't include conflicting versions of Netty.
> It seems like this problem started when FLINK-6084 was implemented: 
> transitive dependencies of the flink-connector-cassandra were previously 
> omitted, and now that they are included we must make sure that they agree 
> with the Flink distribution.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to