Github user paul-guo- commented on a diff in the pull request:
    --- Diff: src/backend/executor/nodeMaterial.c ---
    @@ -41,14 +41,16 @@
     #include "postgres.h"
     #include "executor/executor.h"
    -#include "executor/nodeMaterial.h"
     #include "executor/instrument.h"        /* Instrumentation */
     #include "utils/tuplestorenew.h"
    +#include "executor/nodeMaterial.h"
     #include "miscadmin.h"
     #include "cdb/cdbvars.h"
    +#include "postmaster/primary_mirror_mode.h"
    +int fd_tmp_writer = -1;
    --- End diff --
    1. Use "static" if it is used in the file only. 
    2. I'd suggest you should a more meaningful name for this variable and add 
comment here.

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at or file a JIRA ticket
with INFRA.

Reply via email to