[ 
https://issues.apache.org/jira/browse/HBASE-12490?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14224866#comment-14224866
 ] 

Nicolas Liochon commented on HBASE-12490:
-----------------------------------------

For stuff like:
{code}
-    ht.setAutoFlush(false, false);
+    ht.setAutoFlush(false);
{code}

It's not a big deal, but I don't really like the 'setAutoFlush(boolean)', 
because it looks like a setter while actually it's not. I do prefer 
'setAutoFlush(boolean, boolean)' because there is no confusion with a setter, 
so it's easier for the reader. The implicit setting of the clearBufferOnFail on 
something named like a setter is really confusing imho.  I'm not -1, but I'm 
-0, if I'm the only one confused here... :-)

> Replace uses of setAutoFlush(boolean, boolean)
> ----------------------------------------------
>
>                 Key: HBASE-12490
>                 URL: https://issues.apache.org/jira/browse/HBASE-12490
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 2.0.0, 0.99.2
>            Reporter: Solomon Duskis
>            Assignee: Solomon Duskis
>         Attachments: HBASE-12490.patch, HBASE-12490B.patch, 
> HBASE-12490B.patch, HBASE-12490B.patch, HBASE-12490C.patch
>
>
> The various uses of setAutoFlush() seem to need some tlc.  There's a note in 
> HTableInterface: "@deprecated in 0.99 since setting clearBufferOnFail is 
> deprecated. Use setAutoFlushTo(boolean) instead."  It would be ideal to 
> change all internal uses of setAutoFlush(boolean, boolean) to use 
> setAutoFlushTo, if possible.
> HTable.setAutoFlush(boolean, boolean) is used in a handful of places.  
> setAutoFlush(false, false) has the same results as 
> HTable.setAutoFlush(false).  Calling HTable.setAutoFlush(false, true) has the 
> same affect as Table.setAutoFlushTo(false), assuming 
> HTable.setAutoFlush(false) was not called previously (by default, the second 
> parameter, clearBufferOnFail, is true and should remain true according to the 
> comments). 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to