[ 
https://issues.apache.org/jira/browse/HBASE-12596?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14618251#comment-14618251
 ] 

Ashish Singhi commented on HBASE-12596:
---------------------------------------

Looks good overall to me apart from some minor nits,
bq. Admin admin = util.getConnection().getAdmin();
close the admin at the end or better include it with in try declaration.

bq. Table table = util.createTable(TABLE_NAME, FAMILIES, splitKeys);
drop the table at the end

bq. Path testDir = util.getDataTestDirOnTestFS("testLocalMRIncrementalLoad");
delete it at the end

{{doIncrementalLoadTest}} and the new test case has some code duplication, why 
not extract it to a local method and refer it ?

(Not related to patch) can you remove the unused import from the test class.

> bulkload needs to follow locality
> ---------------------------------
>
>                 Key: HBASE-12596
>                 URL: https://issues.apache.org/jira/browse/HBASE-12596
>             Project: HBase
>          Issue Type: Improvement
>          Components: HFile, regionserver
>    Affects Versions: 0.98.8
>         Environment: hadoop-2.3.0, hbase-0.98.8, jdk1.7
>            Reporter: Victor Xu
>            Assignee: Victor Xu
>             Fix For: 0.98.14
>
>         Attachments: HBASE-12596-0.98-v1.patch, HBASE-12596-0.98-v2.patch, 
> HBASE-12596-0.98-v3.patch, HBASE-12596-0.98-v4.patch, 
> HBASE-12596-0.98-v5.patch, HBASE-12596-master-v1.patch, 
> HBASE-12596-master-v2.patch, HBASE-12596-master-v3.patch, 
> HBASE-12596-master-v4.patch, HBASE-12596-master-v5.patch, HBASE-12596.patch
>
>
> Normally, we have 2 steps to perform a bulkload: 1. use a job to write HFiles 
> to be loaded; 2. Move these HFiles to the right hdfs directory. However, the 
> locality could be loss during the first step. Why not just write the HFiles 
> directly into the right place? We can do this easily because 
> StoreFile.WriterBuilder has the "withFavoredNodes" method, and we just need 
> to call it in HFileOutputFormat's getNewWriter().
> This feature is enabled by default, and we could use 
> 'hbase.bulkload.locality.sensitive.enabled=false' to disable it.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to