[ 
https://issues.apache.org/jira/browse/HBASE-5788?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13255635#comment-13255635
 ] 

Elliott Clark commented on HBASE-5788:
--------------------------------------

RegionMetricsStorage could be a better name this class holds and mutates the 
numbers that will be exposed as dynamic region metrics.

I'll add the comments, and check the line length.  Not sure how I messed up 
eclipse.

The data members can be package private now that they are in the 
regionserver.metrics package.  I'll check to make sure.

Everything else is accessed in the regionserver package so they need to be 
public :-/

TestRegionServerMetrics covers most of the functionality of the new class but I 
can create a new set of more explicit tests if you think that is needed.
                
> Move Dynamic Metrics storage off of HRegion.
> --------------------------------------------
>
>                 Key: HBASE-5788
>                 URL: https://issues.apache.org/jira/browse/HBASE-5788
>             Project: HBase
>          Issue Type: Improvement
>          Components: regionserver
>            Reporter: Elliott Clark
>            Assignee: Elliott Clark
>            Priority: Minor
>         Attachments: HBASE-5788-0.patch, HBASE-5788-1.patch, 
> HBASE-5788-2.patch
>
>
> HRegion right now has the responsibility of storing static counts and latency 
> numbers for use by the metrics package.  Since these maps are incremented and 
> set from lots of places it makes adding functionality hard.
>  
> So move the metrics functionality into SchemaMetrics making it more than just 
> a class for naming.  The next step will be to simplify the api exposed so 
> that using it will be easier.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to