[ 
https://issues.apache.org/jira/browse/SOLR-18372?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=18106085#comment-18106085
 ] 

Chris M. Hostetter commented on SOLR-18372:
-------------------------------------------

I have no clue why the {{multiple}} localparam was added in 
759df4aacd76226984532fd6bbf8d594680ba361 (which has no Jira associated with it) 
as part of a "refactoring" ... I mean ... I understand the motivation of 
switching the default value of {{{}parseMultipleSources{}}}, but i don't 
understand why that involved adding a _new_ localparam option for what (IIUC) 
should have been an "internal only" code path? (especially w/o any new tests or 
documentation)

 

I also don't understand why {{parseMultipleSources}} (and it's getters and 
setters) were marked {{@Deprecated}} instead of just marking them as 
{{@Internal}} ... especially in a situation where there is clearly an 
(internal) code path that depends on them.

 

Hopefully david has some insights/memory of the motivations here.

 
----
 

As far as the current jira: i would definitely remove the localparam ... it's 
probably find to do that in 10.x since it was never documented? especially 
since i don't think it does anything useful if you try to use it?

i don't have a strong opinions about the other parts of the patch (changing the 
callstack on subqueries to be able to eliminate {{parseMultipleSources}} and 
it's getters and setters)

> Remove FunctionQParser.parseMultipleSources
> -------------------------------------------
>
>                 Key: SOLR-18372
>                 URL: https://issues.apache.org/jira/browse/SOLR-18372
>             Project: Solr
>          Issue Type: Sub-task
>            Reporter: Eric Pugh
>            Assignee: Eric Pugh
>            Priority: Major
>              Labels: pull-request-available
>             Fix For: main(11.0)
>
>          Time Spent: 1h 10m
>  Remaining Estimate: 0h
>
> The field and its getter/setter on `FunctionQParser` have been deprecated 
> since 10.0 with javadoc noting it's "only needed for an unusual use-case and 
> seems hard to support." No replacement — this is a feature removal, not a 
> rename.
> Do add it to the major changes in 11 doc, and an email to the dev@ list.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to